Keysight IXIA IxANVL — автоматизированная библиотека проверки соответствия сетевых протоколов

Детали

Официальная поставка

Оборудование поставляется с официальной документацией и гарантией производителя

Точный подбор

Помогаем выбрать модель с учётом технических требований и условий

Запрос цены

Стоимость оборудования рассчитывается индивидуально по запросу

Оперативная поставка

Обеспечиваем согласованные и оптимальные сроки поставки оборудования

Keysight IXIA IxANVL — библиотека автоматизированной валидации сетевых протоколов и проверки соответствия стандартам. Решение поддерживает RFC, IEEE, MEF и AUTOSAR, негативное и регрессионное тестирование, эмуляцию многоузловых сетей, TCP/IP, IPv6, BGP, OSPF, MPLS, VLAN, DHCP, IPsec, SIP, Carrier Ethernet и Segment Routing, а также работу с Ethernet-интерфейсами от 100M до 400G.

 

 

ТЕХНИЧЕСКОЕ ОПИСАНИЕ

Проблема: вопросы качества продукта

На протяжении всего жизненного цикла продукта необходимо проверять конструкцию устройства. Соответствует ли протокольное программное обеспечение устройства спецификациям? Насколько хорошо устройство обрабатывает трафик от сетевых компонентов, не соответствующих требованиям? Как новая разработка может повлиять на существующий код? Эти вопросы требуют не только точных ответов, но и быстрого решения, поскольку выявление и устранение необходимости доработок продукта в последний момент может потребовать значительных затрат времени и средств.

Решение: валидация, которая снижает затраты и повышает уверенность

С помощью Keysight Automated Network Validation Library (IxANVL) можно быстро и без лишних усилий получить доступ к обширному набору библиотек протоколов и утилит для проверки соответствия протоколам и совместимости. Благодаря усовершенствованному графическому интерфейсу пользователя (GUI) и гибким возможностям автоматизации тестирования IxANVL проста в использовании и предоставляет множество ключевых преимуществ. Эмулируя крупные многоузловые сети, она не только снижает затраты, но и обеспечивает более эффективное тестирование и сокращает сроки выпуска продуктов. Обширное и тщательное автоматизированное тестирование повышает уверенность в качестве продукта.

 

Схема вариантов подключения IxANVL к DUT

 

Хотя IxANVL может работать на минимальной аппаратной конфигурации, например на ПК с операционной системой Linux или Windows и сетевой картой Ethernet, она также хорошо подходит для работы на мощной платформе тестирования и анализа Keysight через драйвер Virtual Network Interface Card (VNIC). Такая гибкость позволяет IxANVL поддерживать стандартные отраслевые тестовые интерфейсы, включая Ethernet 100 Мбит/с / 1GE / 10GE / 25GE / 40GE / 100GE / 400GE. IxANVL обеспечивает тестирование на соответствие, негативное и регрессионное тестирование широкого набора протоколов.

Основные преимущества

Экономия времени и средств

IxANVL позволяет производителям проверять конструкцию устройства на протяжении всего жизненного цикла продукта. Проблемы можно выявлять раньше, предотвращая дорогостоящие доработки в последний момент. IxANVL эмулирует крупные многоузловые сети, которые ранее были экономически недоступны, что обеспечивает более эффективное тестирование и ускоряет выпуск продуктов.

Повышение уверенности

IxANVL повышает уверенность в качестве продукта, обеспечивая обширное и тщательное тестирование, выполняемое автоматически и без контроля оператора.

Результаты тестирования IxANVL позволяют пользователям выполнять следующее:

•Точно определять, в каких местах протокольное программное обеспечение устройства соответствует или не соответствует спецификации.
•Наблюдать, насколько хорошо устройство обрабатывает трафик от сетевых компонентов, не соответствующих требованиям.
•Определять, как новая разработка влияет на существующий код, посредством регрессионного тестирования.

Проверка широкого набора протоколов

•IxANVL поддерживает исчерпывающий список протоколов, включая Bridging, Routing, PPP, TCP/IP, IPv6, IPsec, VPN, MPLS, Carrier Ethernet, Automotive Ethernet, Segment Routing и Multicast.

Методология тестирования

Схема процесса разработки набора тестов IxANVL

Процесс разработки набора тестов IxANVL

IxANVL использует строгий процесс разработки наборов тестов:

Спецификации: построчный анализ спецификации протокола.

Списки тестовых утверждений (TAL):

•Разработка TAL — списка утверждений, которые можно проверить.
•Расширение TAL дополнительными негативными тестами.
•Определение приоритетов и группировка TAL для набора тестов.

Метод тестирования: разработка метода тестирования для каждого принятого тестового утверждения.

Проверка кода набора тестов: постоянная проверка стандартов протоколов (авторами или разработчиками реализаций) в процессе разработки.

Конфигурация тестирования

Набор тестов IxANVL может выполняться на ПК с Linux или Windows с серийно выпускаемыми сетевыми интерфейсными картами (NIC) либо на нагрузочных модулях Keysight через соединение VNIC. ПК тестера соединяется с тестируемым устройством (DUT) через тестовые интерфейсы. В зависимости от конфигурации тестирования может использоваться до шести интерфейсов. IxANVL гибко эмулирует различные системные топологии и создает практически любые тестовые сценарии почти для любого DUT.

IxANVL предоставляет как интерфейс командной строки для автоматизации тестирования, так и удобный GUI, обеспечивающий интуитивное управление выполнением тестов и подробную отчетность. Также доступен пакетный исполнитель для планирования последовательностей запусков регрессионных тестов.

Выполнение тестов

IxANVL классифицирует тестовые случаи по трем категориям: MUST, SHOULD и MAY. Тесты можно выбирать и выполнять на основании их категорий или тестовых топологий.

Интерфейс выбора и выполнения тестов IxANVL

Интерфейс выбора тестов IxANVL позволяет пользователям выбирать и запускать тесты по отдельности или группой.

Тест IxANVL может выполняться одним из двух способов — через GUI или вводом командной строки. В режиме GUI пользователь выбирает набор тестов и тестовые случаи для запуска. В режиме командной строки пользователь вводит команду с параметрами, указывающими, какие тесты следует выполнить и какой требуется уровень вывода.

Во время теста IxANVL отправляет пакеты на DUT в соответствии с разработанным тестом и сравнивает полученные от DUT пакеты с ожидаемыми. После получения этих пакетов IxANVL реагирует в соответствии с возвращенной информацией: может продолжить тест, остановить его, зарегистрировать сообщение об ошибке или выполнить ряд других действий.

Во время теста IxANVL регистрирует ход выполнения в реальном времени. После завершения она указывает, пройден тест или нет, а затем повторяет процесс со следующим тестом, пока не будут выполнены все выбранные тесты.

Результаты тестирования

Пользователи могут задать четыре уровня вывода результатов тестирования:

1. Высокий уровень: базовый результат «пройден/не пройден».

2. Средний уровень: результат «пройден/не пройден» и состояние событий теста.

3. Низкий уровень: полный отчет с декодированием пакетов.

4. Hexdump: подробный отчет с шестнадцатеричным дампом каждого пакета, которым обменивались тестер и DUT.

Результаты IxANVL включают подробные трассировочные данные с описанием методологии тестирования для удобного параллельного сопоставления.

Интерфейс результатов тестирования IxANVL

Помимо журналов вывода, IxANVL предоставляет временную диаграмму, отражающую взаимосвязь тестовых пакетов, которыми обмениваются IxANVL и DUT.

Временная диаграмма и анализ пакетов IxANVL

IxANVL обеспечивает комплексный покадровый анализ каждого тестового случая.

Платформа

•Рабочая станция IxANVL поддерживает следующую конфигурацию: Debian 12.7 (Linux debian 6.1.0-25-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.106-3 (2024-08-26) x86_64 GNU/Linux).
•Windows 10 Enterprise (64-bit), Windows Server 2016.
•CPU: 64-битные процессоры.
•RAM: 2 ГБ или более.
•Диск: 4 ГБ свободного пространства или более.

Поддерживаемые интерфейсы

IxANVL поддерживает широкий диапазон сетевых интерфейсных карт, непосредственно подключаемых к ПК с Linux или Windows:

•Ethernet 10/100.
•Gigabit Ethernet.

IxANVL также поддерживает Keysight VNIC — драйвер интерфейса, размещаемый на рабочей станции Linux и шасси Keysight и позволяющий наборам тестов IxANVL получать доступ к нагрузочным модулям Keysight.

Keysight VNIC поддерживает следующие типы нагрузочных модулей Keysight (требуется CPU на каждый порт):

•10 Gigabit Ethernet, включая семейство NGY.
•Ethernet 25GE/40GE/100GE/400GE.
•Семейство Ethernet (10/100/1000 Мбит/с).
•Апплайанс Novus ONE / Novus ONE PLUS.

Покрытие тестирования

Наборы тестов IxANVL Целевые протоколы Справочная спецификация Тестовые случаи / требуемые тестовые интерфейсы
Наборы тестов IPv6
IPv6 Core IPv6 RFC 2460, 2464, 8200 126 / 2
IPv6CP RFC 2472 17 / 1
ICMPv6 RFC 4443 46 / 2
IPv6 Advanced NDP RFC 4861 228 / 2
Generic Packet Tunneling RFC 2473 46 / 2
AutoConfig RFC 4862 37 / 2
V6oV4 RFC 4213, 2529, 3056, 3068 66 / 2
PMTU RFC 1981, 8201 10 / 1
IP Router Alert RFC 2711 13 / 2
DHCPv6 DHCPv6 Client RFC 3315 103 / 1
DHCPv6 Server RFC 3315 141 / 2
DHCPv6 Client PD DHCPv6 Client Prefix Delegation RFC 3633; RFC 8415 35 / 1
Наборы тестов IPv4
IPv4 IPv4 RFC 791, parts of 1122, 1812 70 / 2
ICMP RFC 792, parts of 1812 32 / 2
ARP ARP RFC 826; RFC 1027 61 / 2
DHCPv4 DHCPv4 Client RFC 2131 90 / 2
DHCPv4 Server RFC 2131 74 / 2
Наборы тестов маршрутизации
IP RIP RIP RFC 2453 53 / 2
IPGW RFC 1812, 1122 18 / 2
RIPng RIPng RFC 2080 60 / 2
OSPF Core OSPF RFC 1583, 2328 312 / 3
OSPF Extensions Opaque LSA, NSSA, DB Overflow, Stub Router Ext RFC 2370, 3101, 1765, 3137 56 / 3
OSPF TE OSPF TE RFC 3630 54 / 2
OSPFv3 OSPFv3 RFC 5340, parts of RFC 2328 328
OSPF-GR OSPFv2-GR RFC 3623 56 / 2
VRRP VRRP RFC 3768; RFC 5798 83 / 2
BGP4 Core BGP RFC 4271 217 / 3
BGP4 Extensions BGP-OSPF, Communities, Route Flap Damping, Route Reflection, Route Refresh, Confederations RFC 1403, 1997, 2439, 2918, 4456, 5065, 1771, 4360 150 / 3
BGP Plus BGP+ with IPv6 RFC 4271, 4760, 2545 236 / 3
OSPFv3-AF Support of Address Families in OSPFv3 RFC 5838 37 / 2
BGP 4-Byte AS 4-byte AS for BGP and BGPPlus RFC 4893 52 / 3
ISIS ISIS RFC 1195, 3719, 5303, 5309 237 / 2
ISIS-TE ISIS-TE RFC 3784 31 / 1
ISISv6 ISISv6 ISO/IEC 10589:1992(E); RFC 1195; RFC 3719; RFC 5308 220 / 2
ISIS-MT ISIS-MT RFC 5120, 5303, 5309 105 / 3
VRRPv6 VRRPv3 over IPv6 RFC 5798 77 / 2
BFD BFD Base, BFD Generic, BFD-v4v6-1hop for OSPFv2/v3, ISIS, BFD-BGP, BFDv6-BGPPLUS, BFD-MPLS draft-ietf-bfd-base-09.txt; draft-ietf-bfd-generic-05.txt; draft-ietf-bfd-v4v6-1hop-09.txt; draft-ietf-bfd-mpls-07.txt 178 / 3
Наборы тестов MPLS
MPLS Label Encapsulation RFC 3032 59 / 2
RSVP-TE RSVP-TE RFC 3209, draft-ietf-mpls-rsvp-lsp-tunnel-07 87 / 3
RSVP-TE RSVP-TE P2MP RFC 4875 48 / 3
LDP LDP RFC 3036 329 / 3
mLDP mLDP P2MP draft-ietf-mpls-ldp-p2mp-10 97 / 4
LSP-Ping-Tr LSP Ping and Traceroute RFC 4379 128 / 2
VCCV Pseudo wire VCCV RFC 5085 70 / 2
L2VPN (PWE3) PWE3-Control RFC 4447 69 / 2
PWE3-Encapsulation RFC 4448, 4618, 4717, 4385, 4623 78 / 2
VPLS VPLS RFC 4762 58 / 4
VPLS-BGP VPLS with BGP AD and signaling RFC 4761 46 / 4
L3 VPN L3 VPN RFC 4364 101 / 3
MPLS-TP-Y1731-CC-LD MPLS-TP-Y1731-CC-LD RFC 5586 (GACH), draft-bhh-mpls-tp-oam-y1731-06.txt, ITU-T-REC Y.1731-200605-I 85 / 1
MPLS-TP-IETF-CC-CV-LD MPLS-TP-IETF-CC-CV-LD RFC 5586 (GACH), draft-ietf-mpls-loss-delay-01, draft-ietf-mpls-tp-on-demand-cv-02, draft-ietf-mpls-tp-cc-cv-rdi-03 210 / 1
MPLS-TP-G.8031-APS-Y.1731 MPLS-TP-G.8031-APS-Y.1731 G.8031_Y.1342-2006-06 140 / 2
Наборы тестов многоадресной передачи
IGMP IGMPv2 RFC 2236 49 / 2
IGMPv3 RFC 3376; RFC 4604 169 / 2
DVMRP DVMRP draft-ietf-idmr-dvmrp-v3-07 66 / 3
PIM Dense Mode draft-ietf-pim-dm-new-v2-04 162 / 3
Sparse Mode, SSM RFC 4601, draft-ietf-pim-sm-bsr-12 327 / 3
PIMv6 Sparse Mode draft-ietf-pim-sm-v2-new-12, draft-ietf-pim-sm-bsr-12 283 / 3
MLD MLDv1 RFC 2710 98 / 2
MLDv2 RFC 3810 202 / 2
Наборы транспортных тестов
TCP Core TCP RFC 793, 1122, 2460 179 / 2
TCP Advanced Slow Start, Congestion Control, PMTU Disc, MD5 RFC 2001, 2581, 1191, 2385, 2463, 1981 57 / 1
TCP High Performance Ext for High Performance, Selective Ack RFC 1323, 2018 48 / 1
UDP UDP RFC 768, 1122 35 / 1
Наборы тестов VPN
IPSec AH MD5, SHA RFC 4301, 4302 58 / 2
IPSec ESP MD5, SHA, DES, 3DES, Blowfish, AES RFC 4301, 4303, 2403, 2404, 2405 72 / 2
IPSec IKE ISAKMP, IKE RFC 2407, 2408, 2409 373 / 2
IPSec AH / IPv6 MD5, SHA, IPSecv6 RFC 4301, 4302 66 / 2
IPSec ESP / IPv6 MD5, SHA, DES, 3DES, Blowfish, AES RFC 4301, 4303, 2403, 2404, 2405, 2406 74 / 2
IPSec IKE / IPv6 ISAKMP, IKE RFC 2407, 2408, 2409 384 / 2
IKEV2 IKEV2, DES, 3DES, AES-128, 256, 192, MD5, SHA, DH-768, 1024, 1536, 2048, 3072, AES_GCM_128, AES_GCM_256 RFC 7296 296 / 2
L2TP L2TP RFC 2661 105 / 1
PPTP PPTP draft-ietf-pppext-pptp-02 55 / 1
IKEV2-IPV6 IKEV2-IPV6 RFC 4306, RFC 5996 204 / 2
Наборы тестов Automotive Ethernet
Поддерживаемые спецификации автомобильного тестирования OPEN Alliance TC11 specification—TC11_TestSpecification_Switch_V1.0_final-2019.pdf; OA_Automotive_Ethernet_ECU_TestSpecification_Layer_3-7_v3.0_final.docx; OA_Automotive_Ethernet_ECU_TestSpecification_Layer_2_v3.0; AUTOSAR Acceptance Tests 1.1; AUTOSAR Testability Protocol and Service Primitives 1.1—выполнение с использованием последнего stub protocol; AUTOSAR Specification of TCP/IP Stack V1.1.0 R4.1 Rev2; AUTOSAR Example for a Serialization Protocol (SOME/IP) V1.1.0 R4.1; AUTOSAR Specification of Service Discovery V1.2.0 R4.1 Rev 3
AUTO-ETH-ARP AUTO-ETH-ARP RFC 826 52 / 1
AUTO-ETH-DHCP-SERVER AUTO-ETH-DHCP-SERVER RFC 2131; RFC 2132 74 / 1
AUTO-ETH-DHCPV4-CLIENT AUTO-ETH-DHCPV4-CLIENT RFC 2131, RFC 2132 90 / 1
AUTO-ETH-DHCPV6-CLIENT AUTO-ETH-DHCPV6-CLIENT RFC 3315 104 / 1
AUTO-ETH-DHCPV6-SERVER AUTO-ETH-DHCPV6-SERVER RFC 3315 141 / 1
AUTO-ETH-ICMP AUTO-ETH-ICMP RFC 792, RFC 1122 21 / 1
AUTO-ETH-ICMPV6 AUTO-ETH-ICMPV6 RFC 2463, RFC 4443 24 / 1
AUTO-ETH-IP AUTO-ETH-IP RFC 791, RFC 1122, RFC 894; AUTOSAR_ATS_IPv4.pdf 29 / 1
AUTO-ETH-IPV4-ACONF AUTO-ETH-IPV4-ACONF RFC 3927 56 / 1
AUTO-ETH-IPV6 AUTO-ETH-IPV6 RFC 2460 and RFC 2464 80 / 1
AUTO-ETH-IPV6-AUTOCONFIG AUTO-ETH-IPV6-AUTOCONFIG RFC 4862 34 / 1
AUTO-ETH-IPV6-MLD AUTO-ETH-IPV6-MLD RFC 2710 46 / 1
AUTO-ETH-IPV6-NDP AUTO-ETH-IPV6-NDP RFC 4861 83 / 1
AUTO-ETH-TCP-ADVANCED AUTO-ETH-TCP-ADVANCED RFC 793, RFC 2001, RFC 1191, RFC 2385, RFC 2463, RFC 1981, RFC 813, RFC 896 and AUTOSAR_SWS_TcpIp.pdf (AUTOSAR Specification of TCP/IP Stack V1.1.0 R4.1 Rev2); AUTOSAR_ATS_TCP.pdf 63 / 1
AUTO-ETH-TCP-CORE AUTO-ETH-TCP-CORE RFC 793, RFC 1122, RFC 2460 and AUTOSAR_SWS_TcpIp.pdf (AUTOSAR Specification of TCP/IP Stack V1.1.0 R4.1 Rev2); AUTOSAR_ATS_TCP.pdf 177 / 1
AUTO-ETH-IPV6-MLDV2 AUTO-ETH-IPV6-MLDV2 RFC 3810 85 / 1
SOMEIP-SERVER SOMEIP-SERVER Example for a Serialization Protocol (SOME/IP) V1.1.0 R4.1 Rev 3, Document ID 637, AUTOSAR_TR_SomeIpExample.pdf; Specification of Service Discovery V1.2.0 R4.1 Rev 3, Document ID 616: AUTOSAR_SWS_ServiceDiscovery.pdf 105 / 1
AUTO-ETH-IPV6OV4 AUTO-ETH-IPV6OV4 RFC 4213, RFC 2529 37 / 1
AUTO-ETH-UDP AUTO-ETH-UDP RFC 768 and AUTOSAR_SWS_TcpIp.pdf (AUTOSAR Specification of TCP/IP Stack V1.1.0 R4.1 Rev2); AUTOSAR_ATS_UDP.pdf 35 / 1
TC8-AUTO-ETH-IPV4-ACONF TC8-AUTO-ETH-IPV4-ACONF OpenAlliance v3.0 test specification 56 / 1
TC8-AUTO-ETH-UDP TC8-AUTO-ETH-UDP OpenAlliance v3.0 test specification 74 / 1
TC8-AUTO-ETH-ARP TC8-AUTO-ETH-ARP OpenAlliance v3.0 test specification 52 / 1
TC8-AUTO-ETH-DHCPV4-CLIENT TC8-AUTO-ETH-DHCPV4-CLIENT OpenAlliance v3.0 test specification 90 / 1
TC8-SOMEIP-SERVER TC8-SOMEIP-SERVER OpenAlliance v3.0 test specification 117 / 1
TC8-AUTO-ETH-TCP-CORE TC8-AUTO-ETH-TCP-CORE OpenAlliance v3.0 test specification 197 / 1
TC8-AUTO-ETH-TCP-ADVANCED TC8-AUTO-ETH-TCP-ADVANCED OpenAlliance v3.0 test specification 71 / 1
TC8-AUTO-ETH-IP TC8-AUTO-ETH-IP OpenAlliance v3.0 test specification 53 / 1
TC8-AUTO-ETH-ICMP TC8-AUTO-ETH-ICMP OpenAlliance v3.0 test specification 21 / 1
TC8-SOMEIP-ETS TC8-SOMEIP-ETS OA_Automotive_Ethernet_ECU_TestSpecification_Layer_3-7_v3.0_final.docx 146 / 1
TC11 ARP, VLAN, Filtering, QoS, General, Diagnostic TC11_TestSpecification_Switch_V1.0_final-2019.pdf 161 / 4
TC8-AUTO-ETH-L2 TC8-AUTO-ETH-L2 OA_Automotive_Ethernet_ECU_TestSpecification_Layer_2_v3.0 70 / 16
Наборы тестов PPP
PPP LCP, PPP, PPP in HDLC RFC 1661, 1662 111 / 2
Authentication (PAP, CHAP) RFC 1334, 1994 37 / 1
IPCP IPCP RFC 1332 19 / 2
VJ VJ Compression RFC 1144 48 / 2
PPPoE PPP over Ethernet RFC 2516 75 / 2
Multilink PPP MPPP Multi-class Extension RFC 1717, 1990, RFC 2686 59 / 3
Наборы тестов Carrier Ethernet
MEF9 MEF9 MEF1, MEF9, Iometrix Test Plan version 1.4 247 / 6
EtherCFM Ethernet CFM IEEE P802.1ag/D8.1 2007 246 / 3
EtherOAM Ethernet OAM IEEE 802.3-ah-2004 166 / 3
MEF OAM MEF21 OAM MEF 21 Abstract Test Suite for UNI Type 2 187 / 2
Service OAM Y.1731 ITU-T Y.1731 05/2006, IEEE P802.1ag/D8.1 June 8, 2007 106 / 2
Provider BB PBB IEEE 802.1ah D4.2 2005 55 / 2
MEF Service OAM MEF Service OAM ATS for UNI Type 2 Part 3 — Service OAM 157 / 2
CE2.0 CE2.0 CARRIER ETHERNET 2.0 TEST PLAN — PART 1: SERVICES ATTRIBUTES — Version 1.0; CARRIER ETHERNET 2.0 TEST PLAN — PART 2: TRAFFIC MANAGEMENT — Version 2.0 635 / 6
MEF ELMI MEF ELMI D00063_004 ATS for UNI Type 2 Part 2 ELMI TC; MEF 16 239 / 2
G8031 G.8031 1:1 protection Ethernet Automatic Protection Switching – ITU-T G8031/Y.1342 283 / 3
G_8265_1 G_8265_1 IEEE 1588 Conformity Test Suite for Frequency Synchronization in Telecommunications Networks, Draft Version 2.0 348 / 1
Наборы тестов Bridging
STP 802.1d IEEE Std. 802.1D-1998 53 / 3
RSTP 802.1w IEEE Std. 802.1D-2004 126 / 4
EAPOL 802.1x, MD5, TLS, TTLS IEEE 802.1x-2004 83 / 3
MSTP 802.1s IEEE 802.1Q-2005 247 / 4
LLDP LLDP IEEE 802.1AB 2005; IEEE Std 802.1AB-2016 131 / 3
DCBX DCBX DCB Capability Exchange Protocol Specification (Rev 1.0), DCB Capability Exchange Protocol Base Specification (Rev 1.01) 92 / 1
Mcast Snooping IGMP/MLD Snooping RFC 4541 42 / 3
VLAN 802.1q, GMRP, GVRP IEEE Std. 802.1Q-2005 161 / 4
LACP 802.3ad IEEE Std. 802.3-2005 Clause 43 118 / 4
QinQ QinQ IEEE 802.1ad-2005 127 / 2
MVRP/MMRP MVRP, MMRP IEEE Std 802.1ak-2007; IEEE Std 802.1Q™-2005/Cor 1-2008 321 / 3
Наборы тестов SDN
OPENFLOW_1.0 OPENFLOW_1.0 OpenFlow Switch Specification Version 1.0.0 (Wire Protocol 0x01) and OpenFlow Switch Errata v1.0.1 194 / 5
OPENFLOW1.3 OPENFLOW1.3 OpenFlow Switch Specification Version 1.3.2 (Wire Protocol 0x04) 528 / 6
Наборы тестов Segment Routing
ISIS-SR ISIS Segment Routing RFC 8667; RFC 7794 99 / 3
BGP4 SR-TE BGP SR-TE Policy draft-ietf-idr-segment-routing-te-policy-08 78 / 3
ISIS SRv6 ISIS SRv6 draft-ietf-lsr-isis-srv6-extensions-08 84 / 3
OSPFv2 SR OSPFv2 Segment Routing RFC 8665 73 / 3

Информация для заказа

Партномер Описание
924-450-10PBF IxANVL, пакет Framework, плавающая бинарная лицензия. Включает Linux Framework, Windows Framework, IPv6 Framework, Interface — Ethernet, Interface — Async Serial, Interface — Sync Serial, Interface — PPPoE, Interface — VNIC.
924-450-10PF IxANVL, пакет Framework, плавающая лицензия на исходный код.
924-430-10PBF IxANVL, пакет тестирования протоколов, пакет IPv6, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, IPv6 Core, IPv6 Advanced, DHCPv6. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-431-10PBF IxANVL, пакет тестирования протоколов, пакет IPv4, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, IPv4, ARP, DHCPv4. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-432-10PBF IxANVL, пакет тестирования протоколов, пакет IPv4 Routing, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, IP RIP, OSPF Core, OSPF Extensions, OSPF-GR, VRRP, BGP4 Core, BGP4 Extensions, BGP 4 byte AS, ISIS, ISIS-TE, ISIS-MT, BFD. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-434-10PBF IxANVL, пакет тестирования протоколов, пакет IPv6 Routing, плавающая бинарная лицензия. Включает один пакет Framework для последовательного запуска наборов тестов, RIPng, OSPFv3, BGP Plus, OSPFv3-AF, VRRPv6, ISISv6. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-435-10PBF IxANVL, пакет тестирования протоколов, пакет MPLS, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, MPLS, RSVP-TE, RSVP-TE P2MP, LDP, mLDP, LSP-Ping-TR, VCCV, L2VPN-PWE3, VPLS, VPLS-BGP, L3 VPN, MPLS-TP Y1731 CC LD, MPLSTP IETF CC CV LD, MPLSTP G8031 APS Y1731. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-433-10PBF IxANVL, пакет тестирования протоколов, пакет Multicast, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, IGMP, DVMRP, PIM, PIMv6, MLD. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-436-10PBF IxANVL, пакет тестирования протоколов, пакет Transport, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, TCP Core, TCP Advanced, TCP High Perf, UDP. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-437-10PBF IxANVL, пакет тестирования протоколов, пакет IPSecv4, плавающая бинарная лицензия. Включает один пакет Framework для последовательного запуска наборов тестов, IPSec AH, IPSec ESP, IPSec IKE, IKEV2. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-438-10PBF IxANVL, пакет тестирования протоколов, пакет IPSecv6, плавающая бинарная лицензия. Включает один пакет Framework для последовательного запуска наборов тестов, IPSec AH / IPv6, IPSec ESP / IPv6, IPSec IKE / IPv6, IKEV2-IPV6. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-439-10PBF IxANVL, пакет тестирования протоколов, пакет PPP, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, PPP, IPCP, VJ, PPPoE, MultiLINC PPP, L2TP, PPTP. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-440-10PBF IxANVL, пакет тестирования протоколов, пакет Carrier Ethernet, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, MEF9, EtherCFM, EtherOAM, MEF OAM, Service OAM, Provider BB, MEF Service OAM, CE2.0, MEF ELMI, G8031, G_8265_1. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-441-10PBF IxANVL, пакет тестирования протоколов, пакет Bridging, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, STP, RSTP, EAPOL, MSTP, LLDP, DCBX, Mcast Snooping, VLAN, LACP, QinQ, MVRP/MMRP. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-454-10BF IXIA IxANVL, набор тестов на соответствие, плавающая бинарная лицензия; тестовые случаи для ISIS-SR.
924-442-10PBF IxANVL, пакет тестирования протоколов, пакет SDN, плавающая бинарная лицензия; включает один пакет Framework для последовательного запуска наборов тестов, OF1.0, OF1.3. Для одновременного запуска наборов тестов требуется приобретение дополнительных лицензий Framework.
924-427-10BF Ixia IxANVL, набор тестов на соответствие, тесты сетевого и транспортного уровней Automotive Ethernet IPv4 для стека протоколов хоста, клиента и сервера, ВКЛЮЧАЕТ тестовые случаи Autosar, Open Alliance TC8, TC11, плавающая (по всему миру) бессрочная бинарная лицензия, ТРЕБУЕТСЯ 924-450-10PBF Binary Framework Bundle.
924-427-10F Ixia IxANVL, набор тестов на соответствие, тесты сетевого и транспортного уровней Automotive Ethernet IPv4 для стека протоколов хоста, клиента и сервера, ВКЛЮЧАЕТ тестовые случаи Autosar, Open Alliance TC8, TC11, плавающая (по всему миру) бессрочная лицензия на исходный код, ТРЕБУЕТСЯ 924-450-10PF Source Framework Bundle.
924-428-10BF IxANVL, набор тестов на соответствие, обновление тестов сетевого и транспортного уровней Automotive Ethernet IPv6 для стека протоколов хоста, клиента и сервера, плавающая бинарная лицензия; ТРЕБУЕТСЯ 924-040-91BF Framework Upgrade IPv6, 924-427-10BF AUTOMOTIVE-IPv4.
924-428-10F IxANVL, набор тестов на соответствие, обновление тестов сетевого и транспортного уровней Automotive Ethernet IPv6 для стека протоколов хоста, клиента и сервера, плавающая лицензия на исходный код; ТРЕБУЕТСЯ 924-040-91F Framework Upgrade IPv6, 924-427-10F AUTOMOTIVE-IPv4.
924-454-10BF IXIA IxANVL, набор тестов на соответствие, плавающая бинарная лицензия; тестовые случаи для ISIS-SR.
924-429-10BF IXIA IxANVL, набор тестов на соответствие, плавающая бинарная лицензия; тестовые случаи для BGP SR-TE Policy.
924-444-10BF IXIA IxANVL, набор тестов на соответствие, плавающая бинарная лицензия; тестовые случаи для ISIS-SRv6.
924-443-10BF IXIA IxANVL, набор тестов на соответствие, плавающая бинарная лицензия; тестовые случаи для OSPF-SR.
924-453-10BFS IXIA IxANVL, набор тестов на соответствие, тесты сетевого и транспортного уровней Automotive Ethernet IPv4 и IPv6 для стека протоколов хоста, клиента и сервера, плавающая бинарная лицензия по подписке.
924-456-10BFS IXIA IxANVL, набор тестов на соответствие, пакет тестов Automotive Ethernet TC8 Layer 2, плавающая бинарная лицензия по подписке (924-456-10BFS).
924-457-10BF IXIA IxANVL, набор тестов на соответствие, пакет тестов Automotive Ethernet TC8 Layer 2, плавающая (по всему миру) бессрочная бинарная лицензия. ТРЕБУЕТСЯ 924-450-10PBF IxANVL Framework.
924-461-10BF IXIA IxANVL, набор тестов на соответствие, плавающая бинарная лицензия; тестовые случаи для DHCPv6-Client-PD; ТРЕБУЕТСЯ 924-450-10PBF Framework Bundle.

 

Примечание 1: наборы тестов TCP требуют соединения с DUT как снизу, так и сверху целевого уровня TCP. Соединение снизу уровня TCP обеспечивается через традиционный интерфейс физического уровня. Соединение сверху уровня TCP может быть обеспечено только с помощью уникального приложения «TCP Stub», разработанного Keysight. TCP Stub дистанционно контролируется и управляется наборами тестов Keysight TCP. Назначение TCP Stub — формировать необходимое воздействие выше уровня TCP, требуемое для тестирования. TCP Stub представляет собой переносимое приложение на языке C, поставляемое в составе наборов тестов TCP. Клиенты должны скомпилировать TCP Stub для своих целевых систем.

Характеристики:
Название Значение
Тип Программное решение для автоматизированного тестирования соответствия стандартам, совместимости и регрессионного тестирования сетевых устройств L2–L3
Поддерживаемые платформы AresONE, XGS2, XGS12, стандартные ПК и серверы Windows/Linux с Ethernet-интерфейсами
Интерфейсы 100M/1/10/25/40/100/400GE; поддержка нескольких сетевых интерфейсов
Протоколы Ethernet, IPv4/IPv6, TCP/IP, routing, multicast, PPP, MPLS, VPN, IPsec, Carrier Ethernet, Segment Routing, Automotive Ethernet
Особенности RFC- и standards-based conformance-тесты, negative testing, interoperability и regression testing, эмуляция многосегментных L2–L3-сетей, проверка поведения устройств при некорректном протокольном трафике, автоматическое выполнение тестовых наборов и гибкая сценарная автоматизация

 

Автоматизация:

Возможность автоматизации с помощью собственного ПО: интеграция, автоматизация измерений, собственные база данных и VISA-мост.

СПОАИ — специальное программное обеспечение для автоматизации измерений, разработанное на мощностях «Акметрон» — отечественного разработчика программного обеспечения, производителя и крупнейшего поставщика оборудования с 2012 года.

Это клиент-серверное приложение с многопользовательской распределённой архитектурой, которое решает задачи повышения производительности труда на производстве, сокращения длительности измерений и снижения требований к квалификации персонала. ПО внесено в реестр Минцифры: №28145

 

Ключевые преимущества:

  • Полный цикл «под ключ»: от разработки до сопровождения
  • Клиент-серверная архитектура с самостоятельной переналадкой
  • Централизованный сбор и хранение результатов в БД с возможностью миграции в вашу БД
  • Генератор отчетов на основе ваших шаблонов (docx. и xlsx.)
  • Управление приборами с любым типом интерфейса
  • ПО работает на системах Windows, Linux, MacOS, доступна веб-версия

 

Результаты внедрений:

  • Непрерывная работа в автоматическом режиме до 48 часов
  • До 4 500 измерений за этап
  • Одновременное управление 15+ приборами
  • Автоматизация техтренировки и полной программы испытаний выпускаемых изделий — более 10 контролируемых приборов на одном рабочем месте, до 4 500 автоматизированных измерений в каждом этапе, непрерывная работа в автоматическом режиме 24–48 часов
  • Измерение радиотехнических характеристик приемопередающих модулей
  • Автоматизация тестирования фотонных интегральных схем
  • Контроль и испытания СВЧ-усилителей для космических аппаратов

Оплата товаров осуществляется по безналичному расчёту на основании выставленного счёта.
Счёт на оплату формируется после согласования коммерческого предложения и условий поставки.
Реквизиты для оплаты будут предоставлены вместе с подтверждением заказа менеджером компании.

Мы осуществляем доставку продукции во все регионы Беларуси и России.
Условия и стоимость доставки определяются индивидуально для каждого заказа — с учётом объёма, габаритов и адреса получателя.
После оформления заявки наш менеджер свяжется с вами для уточнения всех деталей и подбора оптимального способа доставки.

Возможно вас заинтересует
Оставить номер
Оставьте свой номер и мы вам перезвоним
*Нажимая на кнопку вы соглашаетесь с условиями политики конфиденциальности
Отправить заявку
Keysight IXIA IxANVL — автоматизированная библиотека проверки соответствия сетевых протоколов
Наш менеджер свяжется с вами в ближайшее время
*Нажимая на кнопку вы соглашаетесь с условиями политики конфиденциальности
Оставить номер
Оставьте свой номер и мы вам перезвоним
*Нажимая на кнопку вы соглашаетесь с условиями политики конфиденциальности

Запросить демонстрацию

Заполните форму, и мы подготовим персональное демо «АЭРОСИМ».

Нажимая кнопку, вы соглашаетесь с политикой конфиденциальности